Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1   Report Post  
Old February 23rd 13, 09:08 AM posted to microsoft.public.excel.worksheet.functions
io io is offline
external usenet poster
 
First recorded activity by ExcelBanter: Feb 2013
Posts: 1
Default INDEX MATCH Functions in LibreCalc (Excel) - Non unique valuesreturn wrong index result

Hi,

i have this problem on both Excel 2010 and LibreOffice Cal.

I have 2 worksheets, the first is jsoneuro and the second is called
results

In the jsoneuro worksheet i have the following columns:

currency;symbol;bid;ask;volume;xrates;bid euro;ask euro;

With let's say the following data:

AUD;mtgoxAUD;28.16638;29.25356;11617.1698751;1.276 3;22.0687769333;22.9205986053
AUD;weexAUD;14;28;0;1.2763;10.9692078665;21.938415 733

In the results worksheet i have the following columns:

BUY HERE;€ ASK PRICE;ORIG. ASK;

With let's say the following data:

ruxumJPY;3.9843877053;490;
ruxumHUF;4.4436848402;1300
ruxumHKD;6931372645;48;


In the BUY HERE column i'm using the following function (where INDICE is
INDEX and CONFRONTA is MATCH - italian version):

=INDICE($jsoneuro.B$2:$jsoneuro.B$100;CONFRONTA(B2 ;$jsoneuro.H$2:H$100;0))

This allows me to retrieve the marketplace name from jsoneuro worksheet
where i have a match with the value contained in the cell B2 of my
results worksheet.

The function i have in my € ASK PRICE column is the following (PICCOLO is
SMALL and RIF.RIGA is the ROW REFERENCE):

=PICCOLO($jsoneuro.H$2:H$55;RIF.RIGA($jsoneuro.H2) )


The issue i have is that when i have a non unique value in my column B
(€ ASK PRICE) my worksheet returns always the first result of the match
and not the corresponding one.

How can i sort out this issue?

Thanks for your effort and help.

Regards.
MM.

Reply
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Index and Match functions I think Jim Butler New Users to Excel 9 November 25th 08 02:34 AM
Calculation using result from Index/Match diaare Excel Worksheet Functions 10 October 16th 07 01:10 AM
Find 2nd, 3rd, etc Result with index/match BKO Excel Worksheet Functions 2 June 13th 07 02:00 PM
SUM(INDEX(MATCH) for a range returns different result than SUM! [email protected]ail.com Excel Worksheet Functions 2 September 22nd 06 08:07 AM
Index and Match Functions Damien Excel Worksheet Functions 4 July 29th 06 10:12 PM


All times are GMT +1. The time now is 09:57 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2004-2019 ExcelBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Excel"

 

Copyright © 2017