Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1   Report Post  
Junior Member
 
Posts: 1
Default Convert config file, copy to new sheet while making some changes, may include variabl

I would like to have a macro or something to copy one column to a new sheet while changing some of the text, skipping a few rows, and adding a few.
This would be done over and over restarting each time an "!" is found.
I have attached a sample of what I need.
Source:
sheet 1 column A (Pasted input)
!
interface Vlan728
description Connection to VLAN 728
ip address 192.19.134.131 255.255.255.128
ip access-group any in
ip helper-address 192.19.160.6
no ip redirects
no ip unreachables
shutdown
standby ip 192.19.134.129
standby timers 1 3
standby priority 110
standby preempt delay minimum 3 sync 3
ip pim sparse-dense-mode
!
interface Vlan729
description Connection to VLAN 729
ip address 192.19.135.131 255.255.255.128
ip access-group any in
ip helper-address 192.19.135.6
no ip redirects
no ip unreachables
shutdown
standby ip 192.19.160.129
standby timers 1 3
standby priority 110
standby preempt delay minimum 3 sync 3
ip pim sparse-dense-mode
!
interface Vlan730
description Connection to VLAN 730
ip address 192.19.136.131 255.255.255.128
ip access-group any in
ip helper-address 192.19.160.6
no ip redirects
no ip unreachables
shutdown
standby ip 192.19.136.129
standby timers 1 3
standby priority 110
standby preempt delay minimum 3 sync 3
ip pim sparse-dense-mode
!
interface Vlan731
description Connection to VLAN 731
ip address 192.19.135.131 255.255.255.128
ip access-group any in
ip helper-address 192.19.135.6
no ip redirects
no ip unreachables
shutdown
standby ip 192.19.160.129
standby timers 1 3
standby priority 110
standby preempt delay minimum 3 sync 3
ip pim sparse-dense-mode
!


Result:
Sheet 2 column A (Result)
#
interface Vlan-interface728
description Connection to VLAN 728
ip address 192.19.134.131 255.255.255.128
ip access-group any in
udp-helper server 192.19.160.6
no ip redirects
no ip unreachables
shutdown
vrrp vrid 728 virtual-ip 192.19.134.129
vrrp vrid 728 priority 110
pim sm
#
interface Vlan-interface729
description Connection to VLAN 729
ip address 192.19.135.131 255.255.255.128
ip access-group any in
udp-helper server 192.19.135.6
no ip redirects
no ip unreachables
shutdown
vrrp vrid 729 virtual-ip 192.19.160.129
vrrp vrid 729 priority 110
pim sm
#
interface Vlan-interface730
description Connection to VLAN 730
ip address 192.19.136.131 255.255.255.128
ip access-group any in
udp-helper server 192.19.160.6
no ip redirects
no ip unreachables
shutdown
vrrp vrid 730 virtual-ip 192.19.136.129
vrrp vrid 730 priority 110
pim sm
#
interface Vlan-interface731
description Connection to VLAN 731
ip address 192.19.135.131 255.255.255.128
ip access-group any in
udp-helper server 192.19.135.6
no ip redirects
no ip unreachables
shutdown
vrrp vrid 731 virtual-ip 192.19.160.129
vrrp vrid 731 priority 110
pim sm
#
Attached Files
File Type: zip config.zip (10.5 KB, 30 views)

Last edited by kldailey : September 12th 12 at 05:02 PM Reason: attach file
Reply
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need a macro to include file names in a folder to excel sheet anil Excel Discussion (Misc queries) 0 March 12th 07 09:10 AM
automatically making a copy of a sheet starguy Excel Worksheet Functions 2 April 22nd 06 06:37 AM
automatically making a copy of a sheet starguy Excel Worksheet Functions 0 April 21st 06 11:34 AM
How do I shut off making a backup copy of a file when I save in E. kboley2004 Excel Discussion (Misc queries) 2 December 21st 04 10:41 PM
Creating and using a config file Steven Excel Programming 1 January 20th 04 10:04 AM


All times are GMT +1. The time now is 06:11 AM.

Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Copyright ©2004-2024 ExcelBanter.
The comments are property of their posters.
 

About Us

"It's about Microsoft Excel"